Replace keg image with tap handle image?


#21

Hah, it does sound crazy… But I’m sure we can ferret out the bug somewhere. @jeeden, can you tell me:

  • What browser you’re using
  • What type of image (png, jpg, etc) you are uploading
  • Image file size

thanks!


#22

Chrome, png, 455kb

I have the image on two of my taps now


#23

Thanks! I’ve added some extra logging (again!), which should appear in the top-right corner in case of this error. Let me know if you see it.


#24

I’m set for right now with the images I uploaded to my other taps, but just to see if it would happen and the logging you talked about, I added another tap and tried changing the photo. Didn’t see any different logging or anything different about the page. Selected a photo, clicked the add picture button and nothing, no progress on the browser window like it was trying to load anything. I also looked at my internet traffic from the browser and saw no transfer. I feel like the script just isn’t running.


#25

Found the bug & zapped it!

(I wish there was a simple explanation to share, but it boils down to: a really obscure code path during layout. Thanks for your patience on this!)


#26

Works great for me every time now! Thanks!


#27

Here is a link to the. Outlet image I am using on my dropbox. I just found it on the web. It is png format so no background. I’ll leave it here for a couple of weeks.

Link


#28

Sorry to resurrect an old thread, but this is not working for me either. I have 6 taps and use pool balls as handles. I uploaded .png images of pool balls to override the keg images, and none of them are showing up.

They show up just fine on my preview, but on the actual tap list not at all.

I was just getting this setup, and my tap list is at https://taplist.io/taplist-15104 if that’s helpful for debugging.


#29

I see pool balls on your taplist if that matters. I’m on a desktop computer at the moment.


#30

Thanks for checking! FWIW I eventually figured out this is one of those “it works in the app but not on the web” things. I determined this by downloading the app to an Android tablet and sure enough the images showed up; however, in a browser on the same tablet they did not.

My workaround currently is when I put a new keg on tap to update the logo image for the beer to the correctly numbered pool ball. That works just fine in both the app and in a browser.

It seems sort of silly that the exact same image would work in one place but not the other, but hey, it’s a free service, and I’ve got a reasonable workaround, so I can’t complain.