Replace keg image with tap handle image?


#1

Great work so far Mike, really like what you are doing! I know you have the ability to add an image to a keg (although as I write this my upload ‘failed’ for some reason… it said it sent you an error report), it would cool to be able to substitute another image for the keg image. Many of us home brewers have exotic tap handles that could be photographed and would provide the way to know which keg is on which tap.

IE, I don’t number my 5 taps, so knowing that my Guinness clone is on tap #2 doesn’t really help someone. Knowing that the Guinness is on the tap that looks like a barber pole…does. See what I mean?


#2

Interesting idea! I hadn’t really considered anything “per tap” like images, but that wouldn’t be hard & you give a good example.

I’ll add this to the list, along with “rename tap” which I know would help in a few cases too (e.g. “Left Tap / Right Tap” vs “1 / 2”)

thanks!


#3

Another option: Be able to select either a Tap Handle or a Bottle or both for a Beer.
That way we could let people know if we have it on Tap, In Bottle, or Both.


#4

I hope this is forthcoming… My wife hounds me to label my 5 taps but I don’t want to!


#5

@owenmalbec merry christmas: check out the new “Configure Tap” option:

Customize the image to replace the default keg illustration.


#6

Awesome!..but I’m not sure it is fully functional. I enabled keg picture in the look and feel. I went to the tap and went to configure tap. I selected a picture to upload, but the add picture button doesn’t seem to do anything…:frowning:

Sorry to be the beta tester with the bad news!


#7

I tried with a png and a jpg and couldn’t get an image to upload either. I was thinking of uploading a bottle image.


#8

Hmm, that’s odd! Not having any trouble over here. I’ll look into it, though, please try again on the off chance you were hitting a stale deploy of the site (long shot).


#9

FWIW, it works for me.


#10

It’s now working for me too. I love this feature, thanks Mikey!!!


#11

Excellent! Glad it is working out, enjoy!


#12

Still wasn’t working for me yesterday, but is working for me today! Worked out great to add a bottle image for beers in bottles.


#13

I just tried this. I get to the Configure Tap and select the image to download but when I click the “Add Picture” button, nothing happens. I tried multiple taps and experienced the same issue. Maybe I’m doing something wrong?


#14

I would say keep trying. I have had it work and not work for me at different times. I’m not sure what causes it to work/not work.


#15

Its hit or miss for me too. Tried yesterday and no luck. Tried same image today and it worked. Trying for a different tap and it doesnt work again. Tried IE and Chrome


#16

Hmmm… Not seeing these errors, but I’ve added some extra logging that might help catch it. If you encounter the problem again, you may see a new error message in the top right corner - please report here if so!


#17

Was just playing with it and unable to upload a photo. Didn’t get an error message. I’m able to get into the configure tap, then browse for a file, but when I click “add picture” nothing happens. No “loading” buffer wheel at the top of the chrome browser etc.

It behaves the exact same way as it does if you don’t browse for a photo and click on the “Add picture” button. It seems like it isn’t registering the click event on add picture button or maybe doesn’t recognize a file has been chosen for the upload.

Hope this helps.


#18

That’s the way it was for me on Chrome. Then the next day it worked. I simply assumed that Mikey had fixed something. Maybe it is a cache issue or something?


#19

Yea, I was trying to add my bottle image to another tap when it was working for me last and uploaded the wrong one by mistake. In my haste I managed to delete my original bottle image and now have the default for all the taps :frowning:

I’ve tried at least 2 browsers on 4 computers and a few tablets and phones, same result. It’s like it isn’t running the script. Weird.


#20

This is going to sound crazy, but I think the update is only working on Mondays… or it works again after a Monday has passed. My reasoning is last week on Monday I tried changing the pics as I mentioned above and messed it up by deleting them. Then I couldn’t make a change all week regardless of device.changes, cache deletes, etc. Here it is Monday morning and I was able to change the pics. Does the site reset somehow at the beginning of each week?