Raspberry pi screensaver disable?

#1

I got it all set up but my display timeout after a few minutes. How do I disable that?

#2

Try looking here and see if this helps: http://www.etcwiki.org/wiki/Disable_screensaver_and_screen_blanking_Raspberry_Pi

I don’t use a Pi at the brewery, but I have disabled screen blanking and screen savers in the past on Pis.

#3

Yes. I forgot to update the post before but I did figure it out. For anyone that needs this in the future…

You must go to the terminal and add a few lines

sudo nano ~/.config/lxsession/LXDE-pi/autostart

Then add

@xset s 0 0
@xset s noblank
@xset s noexpose
@xset dpms 0 0 0

At the end it should look like this…

@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@xset s 0 0
@xset s noblank
@xset s noexpose
@xset dpms 0 0 0

#4

This is what I did: (super easy)

sudo apt-get update
sudo apt-get install xscreensaver

Open the screen saver and disable it.

Cheers!

George

1 Like