Raspberry Pi: Reactivating after every reboot

#1

I have my taplist set up on a raspberrypi, and it works and looks great. My only problem is anytime there is a power outage or any other reason that I have to reboot the device, it requires me to re activate it. Is this normal or is there something I can do to fix it so that it will just load the taplist back up without me having to go to a computer and entering the activation code.

Thanks.

#2

Hmmm, that’s not normal. I wonder, is the raspberry pi’s clock set correctly? It’s possible that the clock is wrong, causing the display’s access code to expire.

I found this thread which might be of some help, otherwise we will have to see if anyone else here has ideas:

#3

are you maybe using -kiosk mode in chrome? that would cause that. you need the cookies.

1 Like
#4

I am using the kiosk mode. I didn’t know that that would disable cookies, but that makes sense. Thanks.

#5

Oh, I didn’t know that about kiosk mode! Would you recommend I remove --kiosk from the RPi setup instructions? I don’t remember if there is other merit to using kiosk mode…

#6

sorry, I was thinking of --incognito switch, because that will fix the “restore tabs” pop-up, but that will not use cookies. The --kiosk mode just does full screen.

#7

So I checked and the time issue is not a problem, it’s syncing just fine and is accurate. I also white-listed cookies for taplist.io so it should be getting cookies. But the issue still remains.

#8

Was there a fix for this as I have the same problem? Every time the power cycles on the RPi, I would get a warning saying the Chromium did not shut down correctly and would I like to restore pages. The fix was to add the --incognito switch to the command line that starts chromium. That works well but now I have to activate Taplst io with an authorization code every time the power cycles (every day). That is more annoying and takes more time than ‘X-ing out’ of the Restore pages warning box.

Hoping that there’s a more elegant solution.

Paul

#9

Any updates or solutions for this?

Paul

#10

Hey Paul - Don’t have much daily experience with the Raspberry Pi, but some googling suggests the following might work:

In your ~/.config/autostart file, replace this line:

Exec=/usr/bin/chromium-browser --noerrdialogs --disable-session-crashed-bubble --disable-infobars --kiosk https://www.taplist.io/display

With this:

Exec=/usr/bin/chromium-browser --noerrdialogs --no-first-run --no-default-browser-check --disable-restore-session-state --kiosk --app=https://www.taplist.io/display

Alternatively, the following article suggests a different solution that could be worth a try.

Let me know how it works & I’ll update the setup instructions if it helped. Thanks!

#11

Thanks Mikey. I’ll give it a try and report back.

Paul

1 Like