New update causing issues with pi only

I have a couple displays running pi3 as well as a firestick. a couple days ago there must have been an update that broke my screen orientation which I corrected by changing the pi back to landscape but im still having another issue that popped up where my displays go black every 10 minutes and I have to reactivate them with my mouse or keyboard. has anyone else had this problem and is there a known fix?
Thanks.

Hey there!

Hmm… To my knowledge we haven’t been doing anything unusual to keep the screens awake on Pi devices, so sounding like it could be an unintentional regression. Can you shoot a quick note to support@taplist.io when it happens again, so we can dig into logs?

Jumping on to this thread rather than create a new one as I am also experiencing a sudden issue with screen orientation.

I am using a Lenovo tablet with the display in Portrait mode (3 tap beer list) and previously the entire display was used to show the taps but suddenly this has changed and it now only uses about 1/3 of the screen real estate.

Any ideas?

Is this using the Taplist.io app? If so could you please send a bugreport through the app (menu → send bugreport) so we can look at logs.

It is in the Android app.

To be honest, I can’t find any menu in the app. What am I missing?

It loads straight to the tap list and I can’t see any menu option and hitting the back button for the tablet takes me back to the home screen…?

Landscape mode displays the list over the full screen, but I have it setup in portrait mode.

There’s usually a system-wide “menu” button on android (sometimes hardware, sometimes it’s virtual/onscreen). This pulls up our menu with a few options.

Ah. I think I understand what’s going on. I see the display in your account is configured as landscape (look under Displays, then press configure). The display needs to be configured on Taplist.io for portrait mode - it won’t automatically follow the orientation of the device.

I think the reason this worked before - i.e. while Taplist.io still had it configured as landscape - was some unintentional/undefined behavior in the theme/app.

Once you do configure it as Portrait (and tweak any other options for the desired look), I think that will get it back to your desired look.

If I change it to Portrait mode, the app loads in portrait mode but once the menu appears it gets flipped to landscape.

App Loading:

Menu:

Likewise, if I hold the tablet in landscape mode, the app loads correctly in landscape mode and then rotates the tap list image upon loading.

All other apps display in the correct orientation so I’m sure it isn’t any setting in the tablet itself.

so I had the same rotation issue as pictured by others, I had another entire pi backup that also had both the screen blanking issue after 10 minutes as well as this orientation issue so it was something as a result of an update of some sort in taplist. I noticed when it started the blue splash screen with the circle now shows up on my pi like it did for my firestick display. It was a bit frustrating because the issue occured on a friday night when I was 2 hrs away and I had to head to the brewery and attempt to correct it. in the end I had to install the screensaver app and then disable it to prevent the screen from blanking at 10 minutes. this is because my pis are running the old 1.2 (or 1.3) version and not version 3 like I thought above.

Hmm ok there must be something else here, we are digging in further. @fathergratwick we will be sending you a service credit since disruptive issues are not cool (and they’re rare enough that it’s just good policy)

@cliffo1976 were you able to find the “Menu” / get a bug report out? OK if not. thanks for your patience.

There’s no menu at all that I can locate in the app, it simply loads straight to the tap list with no visible menu present.

Thanks for your help, no rush from my end, mine is just a simple home setup.

Alright, we have pushed an update that may address two issues:

  1. Orientation issue on non-TV devices (@cliffo1976’s issue) - we think this was a regression.
  2. Keep screen activated on RPi (@fathergratwick’s issue) - we can’t find a direct regression on our side, but we’ve added an enhancement that should prevent the screen from idling in more situations.

Could y’all reload your displays when convenient & report back with any issues (or, and ideally, non-issues)? thanks!

Thanks @mikey , can confirm that has resolved my issue.

Thanks again :+1: :slightly_smiling_face:

1 Like

Awesome! Thanks for the report + confirmation, enjoy!