Install on Raspberry Pi


#1

Followed the instructions for installing it on the Pi. When I go to install it with the command “install taplist-io.sh” I get the following error:

pi@tiltpi:~ $ install-taplist-io.sh
bash: install-taplist-io.sh: command not found

install: missing destination file operand after ‘taplist-io.sh’
Try ‘install --help’ for more information.
Any help would be appreciated.


#2

The install-taplist-io.sh script is just the name for the snippet in step 2: Copy and paste the following commands into your pi […] In other words - copy and paste that text in, you can’t run the file directly.

Ref: https://taplist.io/help/raspberry-pi-setup


#3

Ok I have done Step 1 and Step 2 but nothing seems to be installed. Can you give me the command line to install it?


#4

ok tried on another SD card with NOOBS. Did Step 1 and 2 and rebooted but nothing. Can anyone help me out here? Is it because its NOOBS maybe?


#5

This may not be the right answer but here is what is did:

Load latest version of Raspbian OS (Jessie I think)
After fresh install configured and connected to your WiFi
Launch a terminal session and run following commands:

sudo apt-get install unclutter
sudo apt-get update
sudo apt-get upgrade
sudo nano ~/.config/lxsession/LXDE-pi/autostart
add the following lines at the bottom
@xset s off
@xset -dpms
@xset s noblank
@chromium-browser --noerrdialogs --incognito --kiosk https://taplist.io/taplist-XXXXXX

XXXXXX is your tap number. Shows at top of the page when you login to Taplist.io.

Press:CTRL-O to write out
Press: ENTER
Press: CTRL-X to close

Enter command:
sudo reboot

This will restart your Pi and launch the chromium browser into full screen kiosk mode directly to your taplist.
you will have to activate the display the first time (follow taplist.io instructions)

That’s it!

If you want to run your display in portrait mode do the following on your Pi.

Launch terminal and type the following command:
(windows key will open menu if in kiosk mode from above)
sudo nano /boot/config.txt
add the following lines at the bottom:
# Display orientation. Landscape = 0, Portrait CW= 1, Portrait CCW=3
display_rotate=1

Press:CTRL-O to write out
Press: ENTER
Press: CTRL-X to close

Enter command:
sudo reboot

Done!!!


#6

So it won’t work with NOOBS?


#7

Tried it anyway on NOOBs install, got right to end where you CTRL-O and hit ENTER.

Get the following:

Error writing /home/pi/.config/lxsession/LXD-pi/autostart: No such file or directory

Whats your thoughts?


#8

sorry I missed a letter in the command (missed the “E” in “LXDE-pi”. Corrected OP but command should be:

sudo nano ~/.config/lxsession/LXDE-pi/autostart

#9

If using a fresh download of NOOBS from the raspberry pi site you are running Jessie.

NOOBS = New Out Of Box Software
Raspbian-Jessie is the name of the OS