How do I change font color?

I don’t see an option for changing the color of the fonts. Looks like this is sort of ‘automatic’ based on the background colors.

It’s there! Look in Look and Feel settings, under Fonts.